Cleanup of object destruction. No need to have a per-class destruction function. This was a legacy of the distant past when the classes did not have a common base.
diff --git a/libs/rs/rs.spec b/libs/rs/rs.spec
index 0df237f..1a81021 100644
--- a/libs/rs/rs.spec
+++ b/libs/rs/rs.spec
@@ -32,6 +32,10 @@
param size_t len
}
+ObjDestroy {
+ param void *obj
+ }
+
ElementBegin {
}
@@ -56,10 +60,6 @@
ret RsElement
}
-ElementDestroy {
- param RsElement ve
- }
-
TypeBegin {
param RsElement type
}
@@ -73,10 +73,6 @@
ret RsType
}
-TypeDestroy {
- param RsType p
- }
-
AllocationCreateTyped {
param RsType type
ret RsAllocation
@@ -130,10 +126,6 @@
param RsAllocation alloc
}
-AllocationDestroy {
- param RsAllocation alloc
- }
-
AllocationData {
param RsAllocation va
@@ -170,10 +162,6 @@
param RsAllocation alloc
}
-Adapter1DDestroy {
- param RsAdapter1D adapter
- }
-
Adapter1DSetConstraint {
param RsAdapter1D adapter
param RsDimension dim
@@ -201,10 +189,6 @@
param RsAllocation alloc
}
-Adapter2DDestroy {
- param RsAdapter2D adapter
- }
-
Adapter2DSetConstraint {
param RsAdapter2D adapter
param RsDimension dim
@@ -237,9 +221,6 @@
ret RsSampler
}
-SamplerDestroy {
- param RsSampler s
- }
TriangleMeshBegin {
param RsElement vertex
@@ -260,9 +241,6 @@
ret RsTriangleMesh
}
-TriangleMeshDestroy {
- param RsTriangleMesh mesh
- }
TriangleMeshRender {
param RsTriangleMesh vtm
@@ -274,9 +252,6 @@
param uint32_t count
}
-ScriptDestroy {
- param RsScript script
- }
ScriptBindAllocation {
param RsScript vtm
@@ -381,9 +356,6 @@
ret RsProgramFragmentStore
}
-ProgramFragmentStoreDestroy {
- param RsProgramFragmentStore pfs
- }
ProgramFragmentBegin {
@@ -422,10 +394,6 @@
ret RsProgramFragment
}
-ProgramFragmentDestroy {
- param RsProgramFragment pf
- }
-
ProgramVertexBegin {
param RsElement in
@@ -464,9 +432,6 @@
ret RsLight light
}
-LightDestroy {
- param RsLight light
- }
LightSetPosition {
param RsLight light
@@ -498,9 +463,6 @@
param uint32_t primType
}
-SimpleMeshDestroy {
- param RsSimpleMesh mesh
- }
SimpleMeshBindIndex {
param RsSimpleMesh mesh