Populate java objects with native data from a3d file.
Remove legacy constructor from programraster
Make a3d object creation synchronous
Change-Id: Ic7d7547cf6eee6f9a7c6e3ee12cd104e80056a7b
diff --git a/libs/rs/rs.spec b/libs/rs/rs.spec
index 1719029..1b81591 100644
--- a/libs/rs/rs.spec
+++ b/libs/rs/rs.spec
@@ -78,6 +78,19 @@
ret RsElement
}
+ElementGetNativeData {
+ param RsElement elem
+ param uint32_t *elemData
+ param uint32_t elemDataSize
+ }
+
+ElementGetSubElements {
+ param RsElement elem
+ param uint32_t *ids
+ param const char **names
+ param uint32_t dataSize
+ }
+
TypeBegin {
param RsElement type
}
@@ -91,6 +104,12 @@
ret RsType
}
+TypeGetNativeData {
+ param RsType type
+ param uint32_t * typeData
+ param uint32_t typeDataSize
+ }
+
AllocationCreateTyped {
param RsType type
ret RsAllocation
@@ -231,6 +250,11 @@
param const void *data
}
+AllocationGetType {
+ param RsAllocation va
+ ret const void*
+ }
+
SamplerBegin {
}