Jason Sams | d19f10d | 2009-05-22 14:03:28 -0700 | [diff] [blame] | 1 | |
| 2 | |
| 3 | ContextBindSampler { |
| 4 | param uint32_t slot |
| 5 | param RsSampler sampler |
| 6 | } |
| 7 | |
| 8 | ContextBindRootScript { |
| 9 | param RsScript sampler |
| 10 | } |
| 11 | |
| 12 | ContextBindProgramFragmentStore { |
| 13 | param RsProgramFragmentStore pgm |
| 14 | } |
| 15 | |
| 16 | ContextBindProgramFragment { |
| 17 | param RsProgramFragment pgm |
| 18 | } |
| 19 | |
| 20 | ContextBindProgramVertex { |
| 21 | param RsProgramVertex pgm |
| 22 | } |
| 23 | |
| 24 | |
| 25 | ElementBegin { |
| 26 | } |
| 27 | |
| 28 | ElementAddPredefined { |
| 29 | param RsElementPredefined predef |
| 30 | } |
| 31 | |
| 32 | ElementAdd { |
| 33 | param RsDataKind dataKind |
| 34 | param RsDataType dataType |
| 35 | param bool isNormalized |
| 36 | param size_t bits |
| 37 | } |
| 38 | |
| 39 | ElementCreate { |
| 40 | ret RsElement |
| 41 | } |
| 42 | |
| 43 | ElementGetPredefined { |
| 44 | param RsElementPredefined predef |
| 45 | ret RsElement |
| 46 | } |
| 47 | |
| 48 | ElementDestroy { |
| 49 | param RsElement ve |
| 50 | } |
| 51 | |
| 52 | TypeBegin { |
| 53 | param RsElement type |
| 54 | } |
| 55 | |
| 56 | TypeAdd { |
| 57 | param RsDimension dim |
| 58 | param size_t value |
| 59 | } |
| 60 | |
| 61 | TypeCreate { |
| 62 | ret RsType |
| 63 | } |
| 64 | |
| 65 | TypeDestroy { |
| 66 | param RsType p |
| 67 | } |
| 68 | |
| 69 | AllocationCreateTyped { |
| 70 | param RsType type |
| 71 | ret RsAllocation |
| 72 | } |
| 73 | |
| 74 | AllocationCreatePredefSized { |
| 75 | param RsElementPredefined predef |
| 76 | param size_t count |
| 77 | ret RsAllocation |
| 78 | } |
| 79 | |
| 80 | AllocationCreateSized { |
| 81 | param RsElement e |
| 82 | param size_t count |
| 83 | ret RsAllocation |
| 84 | } |
| 85 | |
| 86 | AllocationCreateFromBitmap { |
| 87 | param const char *file |
| 88 | param bool genMips |
| 89 | ret RsAllocation |
| 90 | } |
| 91 | |
| 92 | AllocationUploadToTexture { |
| 93 | param RsAllocation alloc |
| 94 | param uint32_t baseMipLevel |
| 95 | } |
| 96 | |
| 97 | AllocationUploadToBufferObject { |
| 98 | param RsAllocation alloc |
| 99 | } |
| 100 | |
| 101 | AllocationDestroy { |
| 102 | param RsAllocation alloc |
| 103 | } |
| 104 | |
| 105 | |
| 106 | AllocationData { |
| 107 | param RsAllocation va |
| 108 | param const void * data |
| 109 | } |
| 110 | |
| 111 | Allocation1DSubData { |
| 112 | param RsAllocation va |
| 113 | param uint32_t xoff |
| 114 | param uint32_t count |
| 115 | param const void *data |
| 116 | } |
| 117 | |
| 118 | Allocation2DSubData { |
| 119 | param RsAllocation va |
| 120 | param uint32_t xoff |
| 121 | param uint32_t yoff |
| 122 | param uint32_t w |
| 123 | param uint32_t h |
| 124 | param const void *data |
| 125 | } |
| 126 | |
| 127 | |
| 128 | Adapter1DCreate { |
| 129 | ret RsAdapter1D |
| 130 | } |
| 131 | |
| 132 | Adapter1DBindAllocation { |
| 133 | param RsAdapter1D adapt |
| 134 | param RsAllocation alloc |
| 135 | } |
| 136 | |
| 137 | Adapter1DDestroy { |
| 138 | param RsAdapter1D adapter |
| 139 | } |
| 140 | |
| 141 | Adapter1DSetConstraint { |
| 142 | param RsAdapter1D adapter |
| 143 | param RsDimension dim |
| 144 | param uint32_t value |
| 145 | } |
| 146 | |
| 147 | Adapter1DData { |
| 148 | param RsAdapter1D adapter |
| 149 | param const void * data |
| 150 | } |
| 151 | |
| 152 | Adapter1DSubData { |
| 153 | param RsAdapter1D adapter |
| 154 | param uint32_t xoff |
| 155 | param uint32_t count |
| 156 | param const void *data |
| 157 | } |
| 158 | |
| 159 | Adapter2DCreate { |
| 160 | ret RsAdapter2D |
| 161 | } |
| 162 | |
| 163 | Adapter2DBindAllocation { |
| 164 | param RsAdapter2D adapt |
| 165 | param RsAllocation alloc |
| 166 | } |
| 167 | |
| 168 | Adapter2DDestroy { |
| 169 | param RsAdapter2D adapter |
| 170 | } |
| 171 | |
| 172 | Adapter2DSetConstraint { |
| 173 | param RsAdapter2D adapter |
| 174 | param RsDimension dim |
| 175 | param uint32_t value |
| 176 | } |
| 177 | |
| 178 | Adapter2DData { |
| 179 | param RsAdapter2D adapter |
| 180 | param const void *data |
| 181 | } |
| 182 | |
| 183 | Adapter2DSubData { |
| 184 | param RsAdapter2D adapter |
| 185 | param uint32_t xoff |
| 186 | param uint32_t yoff |
| 187 | param uint32_t w |
| 188 | param uint32_t h |
| 189 | param const void *data |
| 190 | } |
| 191 | |
| 192 | SamplerBegin { |
| 193 | } |
| 194 | |
| 195 | SamplerSet { |
| 196 | param RsSamplerParam p |
| 197 | param RsSamplerValue value |
| 198 | } |
| 199 | |
| 200 | SamplerCreate { |
| 201 | ret RsSampler |
| 202 | } |
| 203 | |
| 204 | |
| 205 | TriangleMeshBegin { |
| 206 | param RsElement vertex |
| 207 | param RsElement index |
| 208 | } |
| 209 | |
| 210 | TriangleMeshAddVertex { |
| 211 | param const void *vtx |
| 212 | } |
| 213 | |
| 214 | TriangleMeshAddTriangle { |
| 215 | param uint32_t idx1 |
| 216 | param uint32_t idx2 |
| 217 | param uint32_t idx3 |
| 218 | } |
| 219 | |
| 220 | TriangleMeshCreate { |
| 221 | ret RsTriangleMesh |
| 222 | } |
| 223 | |
| 224 | TriangleMeshDestroy { |
| 225 | param RsTriangleMesh mesh |
| 226 | } |
| 227 | |
| 228 | TriangleMeshRender { |
| 229 | param RsTriangleMesh vtm |
| 230 | } |
| 231 | |
| 232 | TriangleMeshRenderRange { |
| 233 | param RsTriangleMesh vtm |
| 234 | param uint32_t start |
| 235 | param uint32_t count |
| 236 | } |
| 237 | |
| 238 | ScriptDestroy { |
| 239 | param RsScript script |
| 240 | } |
| 241 | |
| 242 | ScriptBindAllocation { |
| 243 | param RsScript vtm |
| 244 | param RsAllocation va |
| 245 | param uint32_t slot |
| 246 | } |
| 247 | |
| 248 | |
| 249 | ScriptCBegin { |
| 250 | } |
| 251 | |
| 252 | ScriptCSetClearColor { |
| 253 | param float r |
| 254 | param float g |
| 255 | param float b |
| 256 | param float a |
| 257 | } |
| 258 | |
| 259 | ScriptCSetClearDepth { |
| 260 | param float depth |
| 261 | } |
| 262 | |
| 263 | ScriptCSetClearStencil { |
| 264 | param uint32_t stencil |
| 265 | } |
| 266 | |
| 267 | ScriptCAddType { |
| 268 | param RsType type |
| 269 | } |
| 270 | |
| 271 | ScriptCSetRoot { |
| 272 | param bool isRoot |
| 273 | } |
| 274 | |
| 275 | ScriptCSetOrtho { |
| 276 | param bool isOrtho |
| 277 | } |
| 278 | |
| 279 | ScriptCSetScript { |
| 280 | param void * ptr |
| 281 | } |
| 282 | |
| 283 | ScriptCCreate { |
| 284 | ret RsScript |
| 285 | } |
| 286 | |
| 287 | |
| 288 | ProgramFragmentStoreBegin { |
| 289 | param RsElement in |
| 290 | param RsElement out |
| 291 | } |
| 292 | |
| 293 | ProgramFragmentStoreColorMask { |
| 294 | param bool r |
| 295 | param bool g |
| 296 | param bool b |
| 297 | param bool a |
| 298 | } |
| 299 | |
| 300 | ProgramFragmentStoreBlendFunc { |
| 301 | param RsBlendSrcFunc srcFunc |
| 302 | param RsBlendDstFunc destFunc |
| 303 | } |
| 304 | |
| 305 | ProgramFragmentStoreDepthMask { |
| 306 | param bool enable |
| 307 | } |
| 308 | |
| 309 | ProgramFragmentStoreDither { |
| 310 | param bool enable |
| 311 | } |
| 312 | |
| 313 | ProgramFragmentStoreDepthFunc { |
| 314 | param RsDepthFunc func |
| 315 | } |
| 316 | |
| 317 | ProgramFragmentStoreCreate { |
| 318 | ret RsProgramFragmentStore |
| 319 | } |
| 320 | |
| 321 | |
| 322 | |
| 323 | ProgramFragmentBegin { |
| 324 | param RsElement in |
| 325 | param RsElement out |
| 326 | } |
| 327 | |
| 328 | ProgramFragmentBindTexture { |
| 329 | param RsProgramFragment pf |
| 330 | param uint32_t slot |
| 331 | param RsAllocation a |
| 332 | } |
| 333 | |
| 334 | ProgramFragmentBindSampler { |
| 335 | param RsProgramFragment pf |
| 336 | param uint32_t slot |
| 337 | param RsSampler s |
| 338 | } |
| 339 | |
| 340 | ProgramFragmentSetType { |
| 341 | param uint32_t slot |
| 342 | param RsType t |
| 343 | } |
| 344 | |
| 345 | ProgramFragmentSetEnvMode { |
| 346 | param uint32_t slot |
| 347 | param RsTexEnvMode env |
| 348 | } |
| 349 | |
| 350 | ProgramFragmentSetTexEnable { |
| 351 | param uint32_t slot |
| 352 | param bool enable |
| 353 | } |
| 354 | |
| 355 | ProgramFragmentCreate { |
| 356 | ret RsProgramFragment |
| 357 | } |
| 358 | |
| 359 | |
| 360 | |
| 361 | ProgramVertexBegin { |
| 362 | param RsElement in |
| 363 | param RsElement out |
| 364 | } |
| 365 | |
| 366 | ProgramVertexCreate { |
| 367 | ret RsProgramVertex |
| 368 | } |
| 369 | |
| 370 | ProgramVertexBindAllocation { |
| 371 | param RsProgramVertex vpgm |
| 372 | param uint32_t slot |
| 373 | param RsAllocation constants |
| 374 | } |
| 375 | |
| 376 | ProgramVertexSetType { |
| 377 | param uint32_t slot |
| 378 | param RsType constants |
| 379 | } |
| 380 | |
| 381 | ProgramVertexSetCameraMode { |
| 382 | param bool ortho |
| 383 | } |
| 384 | |
| 385 | ProgramVertexSetTextureMatrixEnable { |
| 386 | param bool enable |
| 387 | } |
| 388 | |
| 389 | ProgramVertexSetModelMatrixEnable { |
| 390 | param bool enable |
| 391 | } |
| 392 | |