Implement arrays and allocation adapters

WIP: now passing basic tests

Change-Id: I3d8c1ab12975428def225f88a04e24a4158ca69c
diff --git a/rs.spec b/rs.spec
index 183ae8b..2f3cfb5 100644
--- a/rs.spec
+++ b/rs.spec
@@ -88,6 +88,18 @@
     sync
     }
 
+AllocationAdapterCreate {
+    direct
+    param RsType vtype
+    param RsAllocation baseAlloc
+    ret RsAllocation
+}
+
+AllocationAdapterOffset {
+    param RsAllocation alloc
+    param const uint32_t *offsets
+}
+
 ContextFinish {
     sync
     }