Jason Sams | d19f10d | 2009-05-22 14:03:28 -0700 | [diff] [blame] | 1 | |
| 2 | |
Jason Sams | d19f10d | 2009-05-22 14:03:28 -0700 | [diff] [blame] | 3 | ContextBindRootScript { |
| 4 | param RsScript sampler |
| 5 | } |
| 6 | |
| 7 | ContextBindProgramFragmentStore { |
| 8 | param RsProgramFragmentStore pgm |
| 9 | } |
| 10 | |
| 11 | ContextBindProgramFragment { |
| 12 | param RsProgramFragment pgm |
| 13 | } |
| 14 | |
| 15 | ContextBindProgramVertex { |
| 16 | param RsProgramVertex pgm |
| 17 | } |
| 18 | |
Jason Sams | 3eaa338 | 2009-06-10 15:04:38 -0700 | [diff] [blame^] | 19 | AssignName { |
| 20 | param void *obj |
| 21 | param const char *name |
| 22 | } |
Jason Sams | d19f10d | 2009-05-22 14:03:28 -0700 | [diff] [blame] | 23 | |
| 24 | ElementBegin { |
| 25 | } |
| 26 | |
| 27 | ElementAddPredefined { |
| 28 | param RsElementPredefined predef |
| 29 | } |
| 30 | |
| 31 | ElementAdd { |
| 32 | param RsDataKind dataKind |
| 33 | param RsDataType dataType |
| 34 | param bool isNormalized |
| 35 | param size_t bits |
| 36 | } |
| 37 | |
| 38 | ElementCreate { |
| 39 | ret RsElement |
| 40 | } |
| 41 | |
| 42 | ElementGetPredefined { |
| 43 | param RsElementPredefined predef |
| 44 | ret RsElement |
| 45 | } |
| 46 | |
| 47 | ElementDestroy { |
| 48 | param RsElement ve |
| 49 | } |
| 50 | |
| 51 | TypeBegin { |
| 52 | param RsElement type |
| 53 | } |
| 54 | |
| 55 | TypeAdd { |
| 56 | param RsDimension dim |
| 57 | param size_t value |
| 58 | } |
| 59 | |
| 60 | TypeCreate { |
| 61 | ret RsType |
| 62 | } |
| 63 | |
| 64 | TypeDestroy { |
| 65 | param RsType p |
| 66 | } |
| 67 | |
| 68 | AllocationCreateTyped { |
| 69 | param RsType type |
| 70 | ret RsAllocation |
| 71 | } |
| 72 | |
| 73 | AllocationCreatePredefSized { |
| 74 | param RsElementPredefined predef |
| 75 | param size_t count |
| 76 | ret RsAllocation |
| 77 | } |
| 78 | |
| 79 | AllocationCreateSized { |
| 80 | param RsElement e |
| 81 | param size_t count |
| 82 | ret RsAllocation |
| 83 | } |
| 84 | |
Jason Sams | fe08d99 | 2009-05-27 14:45:32 -0700 | [diff] [blame] | 85 | AllocationCreateFromFile { |
Jason Sams | d19f10d | 2009-05-22 14:03:28 -0700 | [diff] [blame] | 86 | param const char *file |
| 87 | param bool genMips |
| 88 | ret RsAllocation |
| 89 | } |
| 90 | |
Jason Sams | fe08d99 | 2009-05-27 14:45:32 -0700 | [diff] [blame] | 91 | AllocationCreateFromBitmap { |
| 92 | param uint32_t width |
| 93 | param uint32_t height |
| 94 | param RsElementPredefined dstFmt |
| 95 | param RsElementPredefined srcFmt |
| 96 | param bool genMips |
| 97 | param const void * data |
| 98 | ret RsAllocation |
| 99 | } |
| 100 | |
| 101 | |
Jason Sams | d19f10d | 2009-05-22 14:03:28 -0700 | [diff] [blame] | 102 | AllocationUploadToTexture { |
| 103 | param RsAllocation alloc |
| 104 | param uint32_t baseMipLevel |
| 105 | } |
| 106 | |
| 107 | AllocationUploadToBufferObject { |
| 108 | param RsAllocation alloc |
| 109 | } |
| 110 | |
| 111 | AllocationDestroy { |
| 112 | param RsAllocation alloc |
| 113 | } |
| 114 | |
| 115 | |
| 116 | AllocationData { |
| 117 | param RsAllocation va |
| 118 | param const void * data |
| 119 | } |
| 120 | |
| 121 | Allocation1DSubData { |
| 122 | param RsAllocation va |
| 123 | param uint32_t xoff |
| 124 | param uint32_t count |
| 125 | param const void *data |
| 126 | } |
| 127 | |
| 128 | Allocation2DSubData { |
| 129 | param RsAllocation va |
| 130 | param uint32_t xoff |
| 131 | param uint32_t yoff |
| 132 | param uint32_t w |
| 133 | param uint32_t h |
| 134 | param const void *data |
| 135 | } |
| 136 | |
| 137 | |
| 138 | Adapter1DCreate { |
| 139 | ret RsAdapter1D |
| 140 | } |
| 141 | |
| 142 | Adapter1DBindAllocation { |
| 143 | param RsAdapter1D adapt |
| 144 | param RsAllocation alloc |
| 145 | } |
| 146 | |
| 147 | Adapter1DDestroy { |
| 148 | param RsAdapter1D adapter |
| 149 | } |
| 150 | |
| 151 | Adapter1DSetConstraint { |
| 152 | param RsAdapter1D adapter |
| 153 | param RsDimension dim |
| 154 | param uint32_t value |
| 155 | } |
| 156 | |
| 157 | Adapter1DData { |
| 158 | param RsAdapter1D adapter |
| 159 | param const void * data |
| 160 | } |
| 161 | |
| 162 | Adapter1DSubData { |
| 163 | param RsAdapter1D adapter |
| 164 | param uint32_t xoff |
| 165 | param uint32_t count |
| 166 | param const void *data |
| 167 | } |
| 168 | |
| 169 | Adapter2DCreate { |
| 170 | ret RsAdapter2D |
| 171 | } |
| 172 | |
| 173 | Adapter2DBindAllocation { |
| 174 | param RsAdapter2D adapt |
| 175 | param RsAllocation alloc |
| 176 | } |
| 177 | |
| 178 | Adapter2DDestroy { |
| 179 | param RsAdapter2D adapter |
| 180 | } |
| 181 | |
| 182 | Adapter2DSetConstraint { |
| 183 | param RsAdapter2D adapter |
| 184 | param RsDimension dim |
| 185 | param uint32_t value |
| 186 | } |
| 187 | |
| 188 | Adapter2DData { |
| 189 | param RsAdapter2D adapter |
| 190 | param const void *data |
| 191 | } |
| 192 | |
| 193 | Adapter2DSubData { |
| 194 | param RsAdapter2D adapter |
| 195 | param uint32_t xoff |
| 196 | param uint32_t yoff |
| 197 | param uint32_t w |
| 198 | param uint32_t h |
| 199 | param const void *data |
| 200 | } |
| 201 | |
| 202 | SamplerBegin { |
| 203 | } |
| 204 | |
| 205 | SamplerSet { |
| 206 | param RsSamplerParam p |
| 207 | param RsSamplerValue value |
| 208 | } |
| 209 | |
| 210 | SamplerCreate { |
| 211 | ret RsSampler |
| 212 | } |
| 213 | |
Jason Sams | 02fb2cb | 2009-05-28 15:37:57 -0700 | [diff] [blame] | 214 | SamplerDestroy { |
| 215 | param RsSampler s |
| 216 | } |
Jason Sams | d19f10d | 2009-05-22 14:03:28 -0700 | [diff] [blame] | 217 | |
| 218 | TriangleMeshBegin { |
| 219 | param RsElement vertex |
| 220 | param RsElement index |
| 221 | } |
| 222 | |
| 223 | TriangleMeshAddVertex { |
| 224 | param const void *vtx |
| 225 | } |
| 226 | |
| 227 | TriangleMeshAddTriangle { |
| 228 | param uint32_t idx1 |
| 229 | param uint32_t idx2 |
| 230 | param uint32_t idx3 |
| 231 | } |
| 232 | |
| 233 | TriangleMeshCreate { |
| 234 | ret RsTriangleMesh |
| 235 | } |
| 236 | |
| 237 | TriangleMeshDestroy { |
| 238 | param RsTriangleMesh mesh |
| 239 | } |
| 240 | |
| 241 | TriangleMeshRender { |
| 242 | param RsTriangleMesh vtm |
| 243 | } |
| 244 | |
| 245 | TriangleMeshRenderRange { |
| 246 | param RsTriangleMesh vtm |
| 247 | param uint32_t start |
| 248 | param uint32_t count |
| 249 | } |
| 250 | |
| 251 | ScriptDestroy { |
| 252 | param RsScript script |
| 253 | } |
| 254 | |
| 255 | ScriptBindAllocation { |
| 256 | param RsScript vtm |
| 257 | param RsAllocation va |
| 258 | param uint32_t slot |
| 259 | } |
| 260 | |
| 261 | |
| 262 | ScriptCBegin { |
| 263 | } |
| 264 | |
| 265 | ScriptCSetClearColor { |
| 266 | param float r |
| 267 | param float g |
| 268 | param float b |
| 269 | param float a |
| 270 | } |
| 271 | |
| 272 | ScriptCSetClearDepth { |
| 273 | param float depth |
| 274 | } |
| 275 | |
| 276 | ScriptCSetClearStencil { |
| 277 | param uint32_t stencil |
| 278 | } |
| 279 | |
| 280 | ScriptCAddType { |
| 281 | param RsType type |
| 282 | } |
| 283 | |
| 284 | ScriptCSetRoot { |
| 285 | param bool isRoot |
| 286 | } |
| 287 | |
| 288 | ScriptCSetOrtho { |
| 289 | param bool isOrtho |
| 290 | } |
| 291 | |
| 292 | ScriptCSetScript { |
Jack Palevich | ec5a20b | 2009-05-28 15:53:04 -0700 | [diff] [blame] | 293 | param void * codePtr |
Jason Sams | d19f10d | 2009-05-22 14:03:28 -0700 | [diff] [blame] | 294 | } |
| 295 | |
Jason Sams | 39ddc950 | 2009-06-05 17:35:09 -0700 | [diff] [blame] | 296 | ScriptCSetText { |
| 297 | param const char * text |
| 298 | param uint32_t length |
| 299 | } |
| 300 | |
Jason Sams | d19f10d | 2009-05-22 14:03:28 -0700 | [diff] [blame] | 301 | ScriptCCreate { |
| 302 | ret RsScript |
| 303 | } |
| 304 | |
| 305 | |
| 306 | ProgramFragmentStoreBegin { |
| 307 | param RsElement in |
| 308 | param RsElement out |
| 309 | } |
| 310 | |
| 311 | ProgramFragmentStoreColorMask { |
| 312 | param bool r |
| 313 | param bool g |
| 314 | param bool b |
| 315 | param bool a |
| 316 | } |
| 317 | |
| 318 | ProgramFragmentStoreBlendFunc { |
| 319 | param RsBlendSrcFunc srcFunc |
| 320 | param RsBlendDstFunc destFunc |
| 321 | } |
| 322 | |
| 323 | ProgramFragmentStoreDepthMask { |
| 324 | param bool enable |
| 325 | } |
| 326 | |
| 327 | ProgramFragmentStoreDither { |
| 328 | param bool enable |
| 329 | } |
| 330 | |
| 331 | ProgramFragmentStoreDepthFunc { |
| 332 | param RsDepthFunc func |
| 333 | } |
| 334 | |
| 335 | ProgramFragmentStoreCreate { |
| 336 | ret RsProgramFragmentStore |
| 337 | } |
| 338 | |
Jason Sams | 3eaa338 | 2009-06-10 15:04:38 -0700 | [diff] [blame^] | 339 | ProgramFragmentStoreDestroy { |
| 340 | param RsProgramFragmentStore pfs |
| 341 | } |
Jason Sams | d19f10d | 2009-05-22 14:03:28 -0700 | [diff] [blame] | 342 | |
| 343 | |
| 344 | ProgramFragmentBegin { |
| 345 | param RsElement in |
| 346 | param RsElement out |
| 347 | } |
| 348 | |
| 349 | ProgramFragmentBindTexture { |
| 350 | param RsProgramFragment pf |
| 351 | param uint32_t slot |
| 352 | param RsAllocation a |
| 353 | } |
| 354 | |
| 355 | ProgramFragmentBindSampler { |
| 356 | param RsProgramFragment pf |
| 357 | param uint32_t slot |
| 358 | param RsSampler s |
| 359 | } |
| 360 | |
| 361 | ProgramFragmentSetType { |
| 362 | param uint32_t slot |
| 363 | param RsType t |
| 364 | } |
| 365 | |
| 366 | ProgramFragmentSetEnvMode { |
| 367 | param uint32_t slot |
| 368 | param RsTexEnvMode env |
| 369 | } |
| 370 | |
| 371 | ProgramFragmentSetTexEnable { |
| 372 | param uint32_t slot |
| 373 | param bool enable |
| 374 | } |
| 375 | |
| 376 | ProgramFragmentCreate { |
| 377 | ret RsProgramFragment |
| 378 | } |
| 379 | |
Jason Sams | 3eaa338 | 2009-06-10 15:04:38 -0700 | [diff] [blame^] | 380 | ProgramFragmentDestroy { |
| 381 | param RsProgramFragment pf |
| 382 | } |
Jason Sams | d19f10d | 2009-05-22 14:03:28 -0700 | [diff] [blame] | 383 | |
| 384 | |
| 385 | ProgramVertexBegin { |
| 386 | param RsElement in |
| 387 | param RsElement out |
| 388 | } |
| 389 | |
| 390 | ProgramVertexCreate { |
| 391 | ret RsProgramVertex |
| 392 | } |
| 393 | |
| 394 | ProgramVertexBindAllocation { |
| 395 | param RsProgramVertex vpgm |
| 396 | param uint32_t slot |
| 397 | param RsAllocation constants |
| 398 | } |
| 399 | |
| 400 | ProgramVertexSetType { |
| 401 | param uint32_t slot |
| 402 | param RsType constants |
| 403 | } |
| 404 | |
| 405 | ProgramVertexSetCameraMode { |
| 406 | param bool ortho |
| 407 | } |
| 408 | |
| 409 | ProgramVertexSetTextureMatrixEnable { |
| 410 | param bool enable |
| 411 | } |
| 412 | |
| 413 | ProgramVertexSetModelMatrixEnable { |
| 414 | param bool enable |
| 415 | } |
| 416 | |